[Getdp] Error compling getdp from the source with MPI support

Serkan Günel serkan.gunel at deu.edu.tr
Fri Mar 21 12:04:47 CET 2014


Hi,

I am trying to compile latest getdp sources (2.4.2) with open mpi support.
I compiled petsc and the gmsh (2.8.3) from the source and generated both
shared and static libraries, and carefully corrected the paths in getdp
cmake. However, I get following error when i issue make

[  1%] Building CXX object CMakeFiles/getdp.dir/Common/Message.cpp.o
/opt/getdp-2.4.2-source/Common/Message.cpp: In member function ‘virtual
void localGetDP::sendMergeFileRequest(const std::string&)’:
/opt/getdp-2.4.2-source/Common/Message.cpp:570: error:
‘GmshMergePostProcessingFile’ was not declared in this scope
/opt/getdp-2.4.2-source/Common/Message.cpp:571: error: ‘RequestRender’ is
not a member of ‘Msg’
/opt/getdp-2.4.2-source/Common/Message.cpp: In member function ‘virtual
void localGetDP::sendProgress(const std::string&)’:
/opt/getdp-2.4.2-source/Common/Message.cpp:576: error: no matching function
for call to ‘Msg::ProgressMeter(int, int, bool, const char*)’
/usr/include/gmsh/GmshMessage.h:72: note: candidates are: static void
Msg::ProgressMeter(int, int, const char*, ...)
/usr/include/gmsh/GmshMessage.h:73: note:                 static void
Msg::ProgressMeter(int, int)
make[2]: *** [CMakeFiles/getdp.dir/Common/Message.cpp.o] Error 1
make[1]: *** [CMakeFiles/getdp.dir/all] Error 2
make: *** [all] Error 2

Here is what i did: to compile petsc :

yum install mpich2  mpich2-devel arpack arpack-devel MUMPS MUMPS-devel
MUMPS-openmpi MUMPS-openmpi-devel hdf5 hdf5-devel.x86_64 gsl gsl-devel

./configure --with-debugging=0 --with-clanguage=cxx
--with-shared-libraries=0 --with-x=0  --download-mumps=1
--download-parmetis=1 --download-scalapack=1 --download-blacs=1
--with-scalar-type=complex --download-openmpi --download-metis

make PETSC_DIR=/opt/petsc PETSC_ARCH=arch-linux2-cxx-opt all

make PETSC_DIR=/opt/petsc PETSC_ARCH=arch-linux2-cxx-opt test

* To compile gmsh

cd /opt

sudo su

wget http://www.geuz.org/gmsh/src/gmsh-stable-source.tgz

tar xvzf gmsh-stable-source.tgz

cd gmsh-2.8.3-source/

mkdir build; cd build

PETSC_DIR=/opt/petsc PETSC_ARCH=arch-linux2-cxx-opt cmake -DENABLE_MPI=1
-DCMAKE_INSTALL_PREFIX=/opt ..

make

make install

* Finally to compile getDP

cd /opt

sudo su

wget http://www.geuz.org/getdp/src/getdp-stable-source.tgz

tar xvzf getdp-stable-source.tgz

cd getdp-2.4.2-source

mkdir build; cd build

PETSC_DIR=/opt/petsc PETSC_ARCH=arch-linux2-cxx-opt cmake -DENABLE_MPI=1
-DCMAKE_INSTALL_PREFIX=/opt ..

ccmake .

make

However got the above message. Inspecting the source I could not determine
where ‘GmshMergePostProcessingFile,  RequestRender and
Msg::ProgressMeter(int, int, bool, const char*) is declared.

This is the 3rd long day i am working on this.I also tried
gmsh-2.8.4-source, getdp-2.4.3 and svn sources with no joy. I will be very
happy if you could help.

 Best Regards,

Assit.Prof..Dr. Serkan Günel
Dokuz Eylül Üniversitesi,
Tınaztepe Kampüsü
Mühendislik Fakültesi
Elektrik ve Elektronik Müh. Böl.
Kaynaklar, Buca
35160 İzmir, TURKEY
Tel   : +90 232 3017192
Fax   : +90 232 4531085
Email : serkan.gunel at deu.edu.tr
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.geuz.org/pipermail/getdp/attachments/20140321/b8e067fc/attachment.html>


More information about the getdp mailing list