Questions - Valparaíso - Chile (LINUX)

Christophe Geuzaine Christophe.Geuzaine at ulg.ac.be
Mon Sep 18 09:01:59 CEST 2000


Alejandro Angulo wrote:
> 
> Christophe:
> 
> I have installed Linux in my PC, but I have had
> problems to run the version Linux of Gmsh. Apparently
> it doesn't load three libraries:
> - libGLU.so.1
> - libGL.so.1
> - libXm.so.1
> and these are associated to 'Mesa3D' and 'Lesstif'. I
> download these applications from the Net, but I have
> not been able to create the binary versions of these
> in appropriate form.  Christophe, could you send me
> binary versions of these libraries or to indicate me
> how to create them in appropriate form (I have read
> the help and I make all they indicate me but always I
> meet with strange and new errors).
> 
> 
> Greetings
> 
> Alejandro.
> 
> PD:- I install LINUX MANDRAKE !!!
>    - I must install the two libraries in the /SRC directory????
> 


You shouldn't have to compile anything: some people already did that for
you. Just pick up the precompiled rpm packages for Mesa and Lesstif. For
example, download

ftp://ftp.hungry.com/pub/hungry/lesstif/bindist/lesstif-0.91.4-1.i386.rpm
ftp://ftp.belnet.be/packages/redhat/redhat-6.2/i386/RedHat/RPMS/Mesa-3.2-2.i386.rpm

and then make 

rpm -Uvh lesstif-0.91.4-1.i386.rpm Mesa-3.2-2.i386.rpm

You should also download the latest version of Gmsh for Linux (I've put
a new version on the web this morning: the old one will not work with
the last version of Lesstif).

http://www.geuz.org/gmsh/latest/gmsh-Linux.tar.gz

and uncompress the archive with

tar zxvf gmsh-Linux.tar.gz

My best,

-- 
Christophe Geuzaine

Tel: +32-(0)4-366.37.10    mailto:Christophe.Geuzaine at ulg.ac.be
Fax: +32-(0)4-366.29.10    http://www.geuz.org



More information about the gmsh mailing list