[Gmsh] Compile Gmsh with OpenCascade support

Martin Vymazal martin.vymazal at vki.ac.be
Mon Feb 15 21:19:33 CET 2010

Hi Dave,

  thanks for the prompt response. I tried to do what you suggested and  
indeed I can configure gmsh with OpenCascade support. The point is  
that after the compilation finishes, an attempt to run gmsh gives me  
the following error:

gmsh: error while loading shared libraries: libTKSTEP.so.0: cannot  
open shared object file: No such file or directory

The library libTKSTEP.so.0 exists in ${MY_OPENCASCADE_BUILD}/lib/,  
where ${MY_OPENCASCADE_BUILD} is the directory in which I compiled  
OpenCascade (version 6.3)

I tried to run cmake both with


and with


but the error remains the same. Just to be sure, by  
"/path/to/opencascade/" you mean the path to the compiled OpenCascade,  
not the path to the source tree, right?


   Martin Vymazal

> cmake -DCMAKE_PREFIX_PATH:string="/path/to/opencascade/"

Quoting David Colignon <David.Colignon at ulg.ac.be>:

> Hi Martin,
> to configure the build, can you launch cmake with the option
> cmake -DCMAKE_PREFIX_PATH:string="/path/to/opencascade/"
> and see if cmake atomatically detects OCC ?
> Regards,
> Dave
> --
> David Colignon, Ph.D.
> Collaborateur Logistique du F.R.S.-FNRS
> CÉCI - Consortium des Équipements de Calcul Intensif
> ACE - Applied & Computational Electromagnetics
> Institut Montefiore B28
> Université de Liège
> 4000 Liège - BELGIQUE
> Tél: +32 (0)4 366 37 32
> Fax: +32 (0)4 366 29 10
> WWW:    http://hpc.montefiore.ulg.ac.be/
> Agenda: http://www.google.com/calendar/embed?src=david.colignon%40gmail.com
> On 15/02/10 16:43, Martin Vymazal wrote:
>> Hello Gmsh users and developers,
>> I compiled OpenCascade 6.3.0 and I can also compile gmsh from source (I
>> just updated from svn repository), but I didn't find information how to
>> link OpenCascade libraries to gmsh. When I launch ccmake from my build
>> directory, I set the option ENABLE_OCC to 'ON', but the resulting gmsh
>> build doesn't have support for OpenCascade. The same happens with 'cd
>> build; cmake -DENABLE_OCC=1"
>> It's a bit strange that I don't have any option to set the path to the
>> opencascade include files and to the actual opencascade library.
>> Exporting the variable CASROOT which contains the path to 'ros'
>> directory inside the OpenCascade source tree doesn't help either. Can
>> you point me to some howto?
>> Thank you,
>> Martin Vymazal
>> ----------------------------------------------------------------
>> This message was sent using IMP, the Internet Messaging Program.
>> _______________________________________________
>> gmsh mailing list
>> gmsh at geuz.org
>> http://www.geuz.org/mailman/listinfo/gmsh

This message was sent using IMP, the Internet Messaging Program.