[Gmsh] Optimization problem related to random generator function?

Cesar Tirado ctirado at miners.utep.edu
Fri Nov 5 00:32:49 CET 2010

I've been running gmsh to generate a 3D mesh of a pavement section of 
the file that I am attaching using the following command
gmsh Geometry3D.geo -3 -optimize -v 0
In some computers I have been encountering problems generating the mesh 
while in others the mesh is generated without any problem.  Sometimes, 
depending on the computer, I get a "Runtime Error !" window or it 
freezes producing no error window.  For this last case if I don't use 
the verbose mode gmsh keeps displaying messages that indicate it is 
running the optimization and that process continues for a long period of 
time and seems to keep running until I kill the process, we don't know 
if that process ever finishes or if it's stuck in a cyclic process.  
Even the same case might work on the same computer one day and not work 
on another.

I also tried using netgen (gmsh Geometry3D.geo -3 -optimize_netgen -v 
0), and a similar thing happened: In some computers where I had problems 
it seemed to work fine by generating the mesh while in others did not, 
and then on the other hand, the error appeared in some computers that 
had no problems before.

I also tried defining the algorithm del3d or front3d (gmsh 
Geometry3D.geo -3 -algo front3d -optimize -v 0) and sometimes it seems 
to help, but still I haven't been able to find something stable.  I must 
add that I am using 32bit processor for all computers and the same 
operating system (Windows XP SP3). I've tried two different versions of 
GMSH (2.5 and 2.4.2).
Is this related to a random generator function or a floating point 
comparison problem? Is there a way to avoid this issue?

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: Geometry3D.geo
URL: <http://www.geuz.org/pipermail/gmsh/attachments/20101104/b1eec2ff/attachment.geo>