[Gmsh] Mesh Problems when changing Versions

Mark Mccrea ummccrem at myumanitoba.ca
Fri Mar 6 21:25:42 CET 2015

Good day.

When I tried adding -optimize as suggested initially the simulation server did not complete running this in an hour. I had left some intentionally coarse meshes with a large length characteristic of 1 around 0.05 diameter wires just to speed up processing during testing.  Reducing the characteristic length to 0.3 had the optimize meshing completing in several minutes.  I may go finer in the future, I just have to see how the effects the file size and processing times, and simulation accuracy.

Running the ElmerSolver there are no error messages.

Plotting a slice through the field map looks good.

Looks like adding  -optimize has solved the problem.

Thank you for your help.

Mark McCrea

From: gmsh <gmsh-bounces at ace20.montefiore.ulg.ac.be> on behalf of Mark Mccrea <ummccrem at myumanitoba.ca>
Sent: Friday, March 06, 2015 11:35 AM
To: Christophe Geuzaine
Cc: gmsh at geuz.org
Subject: Re: [Gmsh] Mesh Problems when changing Versions

Good day.

My apologies for missing those files, they are attached to this email.

I will try the suggested gmsh change and get back with what occurs before the end of today.

Mark McCrea

From: Christophe Geuzaine <cgeuzaine at ulg.ac.be>
Sent: Friday, March 06, 2015 11:30 AM
To: Mark Mccrea
Cc: gmsh at geuz.org
Subject: Re: [Gmsh] Mesh Problems when changing Versions

> On 06 Mar 2015, at 18:11, Mark Mccrea <ummccrem at myumanitoba.ca> wrote:
> Good day.
> I have recently started to have some problems with using gmsh and Elmer to create field maps for use in Garfield++.  Initially using Gmsh 2.6.1 with Elmer library version 7.0 (rev 6109M) under MacOsX 10.8.5 the meshing and solving worked.  For larger meshes and more events I am trying to move to my groups simulation server.
> My meshing and solver commands are:
> >    gmsh n3HeTarget.geo -3 -order 2
> >    ElmerGrid 14 2 n3HeTarget.msh -autoclean
> >    ElmerSolver n3HeTarget-400V.sif
> When moving to the server  it was required to update gmsh from 2.6.1 for 64bit support.  I went to gmsh2.8.5.  I also changed to the newest (at the time) Elmer, version 7 (rev7023).
> Now using the same input files the meshing and elmergrid seem to work but the ElmerSolver now finds a large number of degenerate points in the mesh and gives error messages of the form:
> ERROR:: ElementMetric: Degenerate 3D element: 191783
> ElementMetric: DetG:  -1.735E-18
> ElementMetric: Node: 1 Coord:   9.754E-01   6.739E+00   1.270E+00
> ElementMetric: Node: 2 Coord:   9.754E-01   6.439E+00   1.270E+00
> ElementMetric: Node: 3 Coord:   1.474E+00   6.888E+00   1.233E+00
> ElementMetric: Node: 4 Coord:   1.474E+00   6.289E+00   1.233E+00
> ElementMetric: Node: 5 Coord:   9.754E-01   6.589E+00   1.270E+00
> ElementMetric: Node: 6 Coord:   1.225E+00   6.664E+00   1.252E+00
> ElementMetric: Node: 7 Coord:   1.225E+00   6.813E+00   1.252E+00
> ElementMetric: Node: 8 Coord:   1.225E+00   6.514E+00   1.252E+00
> ElementMetric: Node: 9 Coord:   1.225E+00   6.364E+00   1.252E+00
> ElementMetric: Node: 10 Coord:   1.474E+00   6.589E+00   1.233E+00
> ElementMetric: Node: 2 dCoord:   0.000E+00  -2.995E-01   0.000E+00
> ElementMetric: Node: 3 dCoord:   4.987E-01   1.497E-01  -3.653E-02
> ElementMetric: Node: 4 dCoord:   4.987E-01  -4.492E-01  -3.653E-02
> ElementMetric: Node: 5 dCoord:   0.000E+00  -1.497E-01   0.000E+00
> ElementMetric: Node: 6 dCoord:   2.493E-01  -7.487E-02  -1.827E-02
> ElementMetric: Node: 7 dCoord:   2.493E-01   7.487E-02  -1.827E-02
> ElementMetric: Node: 8 dCoord:   2.493E-01  -2.246E-01  -1.827E-02
> ElementMetric: Node: 9 dCoord:   2.493E-01  -3.744E-01  -1.827E-02
> ElementMetric: Node: 10 dCoord:   4.987E-01  -1.497E-01  -3.653E-02
> it tries to complete the field solution and looks like it might have worked but the field is wrong or won't load in Garfield++.  So while the first error message is given by ElmerSolver but the the .msh generated by gmsh2.8.5 and elmergrid is significantly reduced in size (file size and node count) compared to the original mesh made with gmsh2.6.1,
> Opening either mesh in gmsh seems to look good, all of the physical volumes and the overall mesh volume look good, and similar.
> Has anyone had similar problems?
> or know if the .msh output format has changed?

Can you try "gmsh n3HeTarget.geo -3 -order 2 -optimize" ?

(You forgot to attach the included gf_*.geo geometry files)

> My .geo and .sif files are attached as well as a terminal logs for each setup showing what was done.
> Mark McCrea
> <n3HeTarget.geo><n3HeTarget-400V.sif><TerminalLog-gmsh285onserver-mesh-solve2015_03_05.txt><TerminalLog-gmsh261onserver-mesh-solve2015_03_06.txt>_______________________________________________
> gmsh mailing list
> gmsh at geuz.org
> http://www.geuz.org/mailman/listinfo/gmsh

Prof. Christophe Geuzaine
University of Liege, Electrical Engineering and Computer Science

More information about the gmsh mailing list