[Gmsh] Remesh STL

look mlook at me.com
Thu Jul 2 15:24:20 CEST 2015


Hello Serban,

I appreciated your answer very much. First of all, the issues seems not to be related with version 2.9.3 since I tried with 2.8.6 on OS X and Ubuntu as well.
However it worked pretty well with your attached test.geo as well with test_nach_t13.geo, which has been written by myself, strongly influenced by the t13 tutorial you mentioned.
Next I tried to create some boundary layers around the surfaces of the inner cube. Therefore I added 

Extrude {0,0,-1} {Surface{3}; Layers{2, 0.001};}

to the code (for creating 2 boundary layers of thickness 0.001 at elementary surface 3). But this only works if I don’t add any Compound or physical surface whatsoever. Please see file test_nach_t13_bound.geo! And I couldn’t adjust the boundary layer height properly, no matter what height I specified in the *.geo file.
I went through the gmsh user guide and tried to find sth. about this topic in the mailing list but didn’t get a clue how this is meant to work. Finally I want to mesh geometry a bit more complicated in a wind tunnel but this is really a long term project. I think first I have to understand the principles of gmsh. And compared to other meshers I find it really hard. No offense, I’m always keen on learning sth. new.

I would be glad for any hint, and thank you very much for your answer!

Best regards,

Kate


> Am 26.06.2015 um 09:02 schrieb Serban.Georgescu at uk.fujitsu.com:
> 
> Hello Kate,
>  
> The issue might be related to some recent bug in 2.9.3.
> I am saying this because if I try to remesh with that I get a crash, while remeshing works quite well with an older Gmsh that I have (2.8.6).
>  
> Also, I think you get a better mesh if you follow Tutorial 13 (http://geuz.org/gmsh/doc/texinfo/gmsh.html#t13_002egeo <http://geuz.org/gmsh/doc/texinfo/gmsh.html#t13_002egeo>) and reconstruct the edges as well.
> If not, only the interiors of the faces will remeshed.
> I’ve added an updated test.geo with does this.
>  
> Best regards,
> Serban
>  
> From: gmsh [mailto:gmsh-bounces at ace20.montefiore.ulg.ac.be <mailto:gmsh-bounces at ace20.montefiore.ulg.ac.be>] On Behalf Of look
> Sent: 25 June 2015 11:57
> To: gmsh at geuz.org <mailto:gmsh at geuz.org>
> Subject: [Gmsh] Remesh STL
>  
> Hello everybody,
> 
> I am trying to remesh a very easy trivial *.stl geometry which I previously generated in Blender. Therefore I followed the instructions from a gmsh mailing list post: http://geuz.org/pipermail/gmsh/2011/006887.html <http://geuz.org/pipermail/gmsh/2011/006887.html>
> 
> 1) Open inout.stl in gmsh (with gui)
> 2) Click on Mesh->Reclassify 2D
> 3) Click on "All" in step 1 and step 3, then click on "Reclassify"
> 4) Save the reclassified mesh as a new msh file -> reclassified_inout.msh
> 5) I can see several distinct surfaces when I open this new file and go to Tools/Visibility.
> 6) Write a new file test.geo:
> Mesh.RemeshAlgorithm=1;
> Mesh.CharacteristicLengthFactor=0.05;
>  
> Merge "reclassified_inout.msh";
>  
> CreateTopology;
>  
> Compound Surface(23)={3};
> Compound Surface(24)={4};
> Compound Surface(25)={5};
> Compound Surface(26)={6};
> Compound Surface(27)={7};
> Compound Surface(28)={8};
> Compound Surface(29)={9};
> Compound Surface(30)={10};
> Compound Surface(31)={11};
> Compound Surface(32)={12};
> Compound Surface(33)={13};
> Compound Surface(34)={14};
> 7) Run 
> Code:
> gmsh -2 test.geo
> Unfortunately I get the following error message:
> Code:
> kate at kate-VirtualBox:/media/sf_documents/gmsh/Daten/inout_cubes_vonBlender$ gmsh -2 test.geo
> Info    : Running 'gmsh -2 test.geo' [Gmsh 2.9.3, 1 node, max. 1 thread]
> Info    : Started on Thu Jun 25 11:34:00 2015
> Info    : Reading 'test.geo'...
> Info    : Reading 'reclassified_inout.msh'...
> Info    : 16 vertices
> Info    : Vertex numbering is dense
> Info    : 36 elements
> Info    : Done reading 'reclassified_inout.msh'
> Info    : Creating topology from mesh...
> Info    : Removing duplicate mesh vertices...
> Info    : Found 0 duplicate vertices 
> Info    : No duplicate vertices found
> Info    : Done creating topology from mesh (0.000554 s)
> Info    : Done reading 'test.geo'
> Info    : Meshing 1D...
> Info    : Done meshing 1D (1.7e-05 s)
> Info    : Meshing 2D...
> Info    : Meshing surface 23 (Compound surface, MeshAdapt)
> Info    : Parametrizing surface 23 with 'convex map'
> [0]PETSC ERROR: --------------------- Error Message --------------------------------------------------------------
> [0]PETSC ERROR: Object is in wrong state
> [0]PETSC ERROR: Not for unassembled matrix
> [0]PETSC ERROR: See http://www.mcs.anl.gov/petsc/documentation/faq.html <http://www.mcs.anl.gov/petsc/documentation/faq.html> for trouble shooting.
> [0]PETSC ERROR: Petsc Release Version 3.5.2, Sep, 08, 2014 
> [0]PETSC ERROR: gmsh on a linux_complex_mumps_seq named kate-VirtualBox by kate Thu Jun 25 11:34:00 2015
> [0]PETSC ERROR: Configure options --with-pic --with-blas-lapack-lib="[/usr/local/lib/liblapack.a,/usr/local/lib/libblas.a,-lpthread]" --with-clanguage=cxx --with-debugging=0 --with-mpi=0 --with-x=0 --with-ssl=0 --with-mpiuni-fortran-binding=0 --with-mumps-include=/home/geuzaine/src/mumps_seq/include --with-mumps-lib="[/home/geuzaine/src/mumps_seq/lib/libcmumps.a,/home/geuzaine/src/mumps_seq/lib/libsmumps.a,/home/geuzaine/src/mumps_seq/lib/libdmumps.a,/home/geuzaine/src/mumps_seq/lib/libzmumps.a,/home/geuzaine/src/mumps_seq/lib/libmumps_common.a,/home/geuzaine/src/mumps_seq/lib/libmetis.a,/home/geuzaine/src/mumps_seq/lib/libmpiseq.a,/home/geuzaine/src/mumps_seq/lib/libpord.a]" --with-mumps-serial --with-shared-libraries=0 --with-scalar-type=complex
> [0]PETSC ERROR: #1 MatGetOrdering() line 189 in /home/geuzaine/src/petsc-3.5.2/src/mat/order/sorder.c
> [0]PETSC ERROR: #2 PCSetUp_ILU() line 196 in /home/geuzaine/src/petsc-3.5.2/src/ksp/pc/impls/factor/ilu/ilu.c
> [0]PETSC ERROR: #3 PCSetUp() line 902 in /home/geuzaine/src/petsc-3.5.2/src/ksp/pc/interface/precon.c
> [0]PETSC ERROR: #4 KSPSetUp() line 305 in /home/geuzaine/src/petsc-3.5.2/src/ksp/ksp/interface/itfunc.c
> [0]PETSC ERROR: #5 KSPSolve() line 417 in /home/geuzaine/src/petsc-3.5.2/src/ksp/ksp/interface/itfunc.c
> [0]PETSC ERROR: #6 _try() line 9 in /home/geuzaine/src/gmsh/Solver/linearSystemPETSc.hpp
> Aborted (core dumped)
> I have attached the necessary files to reproduce the problem. I tried with gmsh 2.9.3 on OS X and gmsh 2.9.3 on Ubuntu.
> 
> I would appreciate any help/hint/comment!
> 
> Best regards,
> 
> Kate
> ______________________________________________________________________
> 
>  Fujitsu Laboratories of Europe Limited
>  Hayes Park Central, Hayes End Road, Hayes, Middlesex, UB4 8FE
>  Registered No. 4153469
> 
>  This e-mail and any attachments are for the sole use of addressee(s) and
>  may contain information which is privileged and confidential. Unauthorised
>  use or copying for disclosure is strictly prohibited. The fact that this
>  e-mail has been scanned by Trendmicro Interscan does not guarantee that
>  it has not been intercepted or amended nor that it is virus-free.
> <test.geo>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.geuz.org/pipermail/gmsh/attachments/20150702/2afd555d/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: inout_cubes_vonBlender_2.zip
Type: application/zip
Size: 7223 bytes
Desc: not available
URL: <http://www.geuz.org/pipermail/gmsh/attachments/20150702/2afd555d/attachment.zip>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.geuz.org/pipermail/gmsh/attachments/20150702/2afd555d/attachment-0001.html>


More information about the gmsh mailing list