[Gmsh] Weird error (literally)

John Villarrubia John.Villarrubia at nist.gov
Tue Jul 7 15:43:56 CEST 2015


While attempting to Optimize 3D, GMSH says "Impossible to swap face" and 
then "Error: WEIRD !!!" I'm at a loss concerning how to trouble shoot. 
Any suggestions?

Background:

I'm attempting to mesh a rough surface. To this end I have in another 
software generated a random roughness (which matches a desired power 
spectrum) and wrapped this rough "skin" around a smooth basic shape. My 
other software generates a .geo file that consists of surface points 
specified on a rectangular grid at close intervals, together with edges 
and triangular surfaces that comprise a triangulation of this grid. My 
triangles in the .geo are smaller than GMSH's mesh size, so when I tell 
GMSH to do a surface mesh of this, it is essentially constrained to use 
the triangles I have given it. I close the volume by providing sides and 
a bottom surface, and I want GMSH to then produce the associated 3D mesh 
of the enclosed volume.

At first I tried no mesh size specification (so let GMSH do it's default 
thing). This produces a large number of "Impossible to smooth vertex" 
errors. It nevertheless produces a 3D mesh. However, this mesh is faulty 
(e.g., contains at least one instance of one tetrahedron inside of another).

Then I tried specifying mesh size equal to my triangle edge length for 
nodes in my rough region and equal to the approximate dimension of my 
volume at points far from the surface. GMSH at first locked up and had 
to be manually terminated after several days of CPU usage. Thinking this 
may be due to excessive mesh size, I've pared it down.

It produced a 3D mesh, but when I tried to optimize I got the 
above-mentioned "Impossible to swap face" and then "Error: WEIRD !!!" 
messages followed by a pop-up from the operating system: "GMSH has 
stopped working..."

John






More information about the gmsh mailing list