[Gmsh] Can't open jpg files

Felix Salazar felix.a.salazar at gmail.com
Thu Sep 1 15:49:36 CEST 2016

Thanks for the description of the issue.

As you said, the problem appeared without changing or updating Gmsh.
Regardless of added or removed features on the most recent version of Gmsh,
this points to a problem in your setup, meaning your installation of gmsh
within your Windows machine, and it might be hard to reproduce.

Not sure about which Windows libraries gmsh uses to open jpeg files. But it
might be that one of those libraries in which Gmsh depends got corrupted by
an external party or gmsh itself got corrupted.

Check if the jpeg problem appears in any other software you have. It might
help open the software using a terminal window (not sure if possible in
Windows), so you can get more info of the error. This might even help with
gmsh error. If jpeg are fine everywhere, try to remove completely Gmsh from
your system (folders, hidden folders, configuration files, windows registry
entries, etc). And then reinstall

If the problem persists, you will need to repair the broken library. This
is probably the worst situation. You could probably request additional info
of the gmsh dependencies of the binary file you're using.

I haven't used Windows in many years so I don't know the current way they
handle libraries and where to get the files to repair it. In the old
versions (I'm talking XP here) you could go into Windows Setup and install,
remove or repair individual features. It normally required the Windows
Installation CD/DVD.

Good luck

On Sep 1, 2016 9:22 AM, "Santiago Patiño" <santinpatin at gmail.com> wrote:

> Hi Felix, yes it was working well and when I tried to open another jpeg
> file it crashed. I tried several times with that file and the others which
> had worked well but didn't work also. So, then, I downloaded the latest
> version for windows 64 bits and it still doesn't work. The files were
> edited by me in photoshop and then saved as a jpeg file, I wasn't using an
> official binary nor I compiled anything, that I know, sorry for my
> ignorance.
> 2016-09-01 9:41 GMT-03:00 Felix Salazar <felix.a.salazar at gmail.com>:
>> When you say "suddenly" it means one day it worked and the next it
>> didn't? With the same image or you try something else? The same version of
>> the software or did you do any updates? Are you using an official binary or
>> did you compile it yourself? Are you on Windows or in any other platform? A
>> botched update of the jpeg libs in Linux might cause problems in programs
>> that rely on them. Or maybe these libs were not linked properly during your
>> compilation.
>> On Aug 31, 2016 3:39 PM, "Santiago Patiño" <santinpatin at gmail.com> wrote:
>>> Hi, I've been working with gmsh for a while and suddenly it doesn't open
>>> jpg files anymore. The program just crashes and says that it stopped
>>> working and the only option is to close it.
>>> Hope I can get some help with this because I need gmsh for the analysis
>>> of my thesis, thanks.
>>> Santiago
>>> _______________________________________________
>>> gmsh mailing list
>>> gmsh at onelab.info
>>> http://onelab.info/mailman/listinfo/gmsh
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://onelab.info/pipermail/gmsh/attachments/20160901/d02eb6db/attachment.html>

More information about the gmsh mailing list