[Gmsh] Bug when installing shared library

Aleksejs Fomins aleksejs.fomins at lspr.swiss
Thu Sep 8 17:02:23 CEST 2016

Ok I figured it out, my custom-compiled Lapack did not have dynamic libraries...

Sorry for the noise,


On 08.09.2016 11:53, Aleksejs Fomins wrote:
> Dear GMSH,
> I have tried installing the newest GMSH from source code. First problem I encountered was when the GMSH executable failed to link due to fortran errors. Adding the -lgfortran to the C and CXX Cmake compile flags fixed the problem, and I could compile gmsh.
> Then I tried compiling the shared libraries by following the instructions in README.txt. The static library (.a) compiles fine, but the shared library (.so) throws the following error
> -------------------------
> /usr/bin/ld: /opt/extlib/lapack/3.5.0/gcc/5.2.0/lib/liblapack.a(dgeev.f.o): relocation R_X86_64_32 against `.rodata' can not be used when making a shared object; recompile with -fPIC
> -------------------------
> Inspecting via make VERBOSE=1 has revealed that the -fPIC is indeed passed to the compiler, twice. I tried adding it again to the C and CXX compile flags, but to no avail. See attached the output of above command.
> Please help :)
> Aleksejs Fomins
> _______________________________________________
> gmsh mailing list
> gmsh at onelab.info
> http://onelab.info/mailman/listinfo/gmsh

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://onelab.info/pipermail/gmsh/attachments/20160908/45b402f8/attachment.html>

More information about the gmsh mailing list