[Gmsh] Meshing a surface with an hole

Hugo BORIE hborie14 at gmail.com
Fri May 9 12:16:38 CEST 2014


I'm currently trying to mesh a simple rectangular surface with an hole in
it (square hole).

Unfortunately, I receive every time an error during the meshing part.

I attach a folder with 7 files in it.

p.geo & p.msh : just files to try the meshing with an hole

DOMAINE_PIEZO.geo & DOMAINE_PIEZO.msh : what I want to put in the holes
PLAQUE.geo : the shell that will welcom the DOMAINE_PIEZO
assembly.geo & assembly.msh : the file that combine the two previous files

Has anyone already encountered this problem and tried to solved it? I
didn't find many subject on internet about that.

Thanks for your help,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.geuz.org/pipermail/gmsh/attachments/20140509/3440e7f7/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: plaque_with_hole.zip
Type: application/zip
Size: 820464 bytes
Desc: not available
URL: <http://www.geuz.org/pipermail/gmsh/attachments/20140509/3440e7f7/attachment.zip>