[Gmsh] RE RE Creation of Physical Line with for loop

Pietro Vitali pv.bu.2013 at gmail.com
Fri May 9 14:19:46 CEST 2014

Hello Jean Pierre,

      thank you very much for your reply;
unfortunately it seems not to work; I don't know why but
the for loop does not increment and does not add numbers inside the list beam[].

When I print on screen the numbers that should belong to the list , it returns me just one number
equals to "1".

I suppose I'm wrong with something but I don't know what is is!!

Can you help me?

I added a line of code to create a Physical line and it works....obviously just for the first line!

For z In {1:10}
Physical Line (1) = {beam};

Thank you in advance!!

Pietro Vitali

ps: I hope the subject of the email is correct....sorry I'm a new user!!

Send gmsh mailing list submissions to
	gmsh at geuz.org

To subscribe or unsubscribe via the World Wide Web, visit
or, via email, send a message with subject or body 'help' to
	gmsh-request at geuz.org

You can reach the person managing the list at
	gmsh-owner at geuz.org

When replying, please edit your Subject line so it is more specific
than "Re: Contents of gmsh digest..."

Today's Topics:

    1. RE Creation of Physical Line with for loop (jean pierre aubry)
    2. Meshing a surface with an hole (Hugo BORIE)


Message: 1
Date: Fri, 9 May 2014 10:01:17 +0200
From: jean pierre aubry<jeanpierre at lamachine.fr>
To:gmsh at geuz.org  <gmsh at geuz.org>
Subject: [Gmsh] RE Creation of Physical Line with for loop
Message-ID:<20140509100117.30b7fa83 at dedalus.lbac>
Content-Type: text/plain; charset=US-ASCII


try that

//make a list
//add to the list
For num In {1:100}
      beam[]+= {num}

jean pierre aubry

-- jean pierre aubry 33 688 670 795 ------------------------------ 
Message: 2 Date: Fri, 9 May 2014 12:16:38 +0200 From: Hugo BORIE 
<hborie14 at gmail.com> To: gmsh at geuz.org Subject: [Gmsh] Meshing a surface 
with an hole Message-ID: 
<CAA7wkqrwYuS9dqJsVNBD9m5UuAb1-O7UQNavXBtm5MZ=uha4mw at mail.gmail.com> 
Content-Type: text/plain; charset="utf-8" Hello, I'm currently trying to 
mesh a simple rectangular surface with an hole in it (square hole). 
Unfortunately, I receive every time an error during the meshing part. I 
attach a folder with 7 files in it. p.geo & p.msh : just files to try 
the meshing with an hole DOMAINE_PIEZO.geo & DOMAINE_PIEZO.msh : what I 
want to put in the holes PLAQUE.geo : the shell that will welcom the 
DOMAINE_PIEZO assembly.geo & assembly.msh : the file that combine the 
two previous files .geo Has anyone already encountered this problem and 
tried to solved it? I didn't find many subject on internet about that. 
Thanks for your help, Hugo -------------- next part -------------- An 
HTML attachment was scrubbed... URL: 
-------------- next part -------------- A non-text attachment was 
scrubbed... Name: plaque_with_hole.zip Type: application/zip Size: 
820464 bytes Desc: not available URL: 
_______________________________________________ gmsh mailing list 
gmsh at geuz.org http://www.geuz.org/mailman/listinfo/gmsh End of gmsh 
Digest, Vol 136, Issue 11 *************************************