[Gmsh] Solution Not Converged

ABE Hiroshi habe36 at gmail.com
Fri Sep 15 01:49:36 CEST 2017


I found a statement how to specify the linear solver in FAQ in getdp manual.

I’ve tried several solvers and preconditioners, which would work for many cases, say, cg, gmres, bcgs for solver and icc, ilu, cholesky for preconditioner.
Any combinations could not be converged. The best case is the combination of gmres and icc. The residue was 1.4e-2 for 10000 iteration limit. The others wouldn’t be converged or overflow to stop.

I would like to ask if there some option of getdp to output the matrix of the linear system?

The info of robust combination of solver and preconditioner also be appreciated.

Thank you.

2017/08/07 20:31、ABE Hiroshi <habe36 at gmail.com> のメール:

> Hi All,
> I am studying OneLab for electromagnetic application and looking into a sample, waveguide3D_step.
> The sample working fine as default condition.
> I modified the sample to microwave heating application.
> I changed the second waveguide to be bigger as, 12x12x12 cm. The output Port2 is closed with PEC. A spheric dielectric material is placed at the centre of the second waveguide box.
> If the resolution is set 0.1 which is the default value, gmsh is “killed” by the operating system (ubuntu). May be memory shortage.
> If resolution is set around 0.17 then it cannot converge into a solution. The solution is overflowed (nan). If you want to converge, the resolution value should be set around 0.2 or larger. I cannot figure out the reason why the solution would not converge.
> Ii might be better to be used different stable iterative solver but I don’t know how. Any suggestions would be appreciated.
> I run OneLab on Ubuntu 17.04 with 24GB main memory with core i7.
> When you put the resolution 0.1 with the same model on macOS ,16GB main memory with core i5, Gmsh would stall the macOS system.

ABE Hiroshi
 from Tokorozawa, JAPAN

More information about the gmsh mailing list