[Gmsh] A difference running Gmsh in command line and in GUI for 3-D mesh generation?

范荣红 fanronghong at lsec.cc.ac.cn
Wed Apr 25 17:00:21 CEST 2018

Dear all,

In Gmsh, I have a test.geo file. The question is:

if I run gmsh -3 test.geo in the command line, I get the below error.

Error   : Surface mesh is wrong, cannot do the 3D mesh
Info    : Done meshing 3D (0.002836 s)
Info    : 927 vertices 2064 elements
Error   : ------------------------------
Error   : Mesh generation error summary
Error   :     0 warnings
Error   :     2 errors
Error   : Check the full log for details
Error   : ------------------------------ 

if I partition the test.geo in Gmsh GUI, sometimes I get the same error as above. But if I reload test.geo and then 3D it many times, I am sure I can get the right 3-D partition.

The test.geo file can be obtained from test.geo file

So how does this happen?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://onelab.info/pipermail/gmsh/attachments/20180425/c0188263/attachment.html>

More information about the gmsh mailing list