[Gmsh] Error generating simple mesh

Elisa Schenone elisa.schenone at moxoff.com
Fri Sep 20 09:20:30 CEST 2019

Thank you for your quick answer.

I'm sorry I missed "BottomBox" surface in the surface loop. Adding it does
not fix the problem.
I cannot see why the volume should not be correctly defined since I use the
same 1D entities to define adjacent surfaces.

Actually, the real application is more complicated than the simplified
example I sent you. Instead of the circle surface I have a quite
complicated geometry coming from a stp from which I extracted the boundary
(the 1D mesh I merge in my geo file). Also, I cannot use OpenCascade since
I need some attractor fields and a boundary layer in my real application.

Maybe there is a better way to treat stp file? I need to extract "manually"
its boundary because I'd like to write in my geo something like:
bnd[] = Boundary{Surface{14};};
but I don't know a priori the label of the surface I want to extract the
boundary of.

Even assuming I know the label from which to extract the 1D boundary, I
still have this kind of error:
Error   : Invalid boundary mesh (segment-facet intersection) on surface
121, intersection (50,15,5.57227e-11)
I attach a screenshot too.
I tried to change the sign of surface 93 (which is innermost circle), the
intersection error moves few elements on the right but is the same.

Could it be because of normals?

Thank you,

Il giorno gio 19 set 2019 alle ore 19:59 Christophe Geuzaine <
cgeuzaine at uliege.be> ha scritto:

> > On 19 Sep 2019, at 11:28, Elisa Schenone <elisa.schenone at moxoff.com>
> wrote:
> >
> > Dear gmsh developers,
> >
> > I'm trying to use gmsh to create a cube mesh with a surface separated in
> multiple entities: two concentric circles are inscribed into the top
> surface (square).
> > The external circle comes from a 1D mesh that I merge to my geo script.
> > The internal circle has been created only as a workaround since gmsh
> could not create the 2D mesh inside the 1D line (file circleLine1.mesh or
> circleLine2.mesh).
> >
> > Small changes in the script, i.e. characteristic length, line1 or line2,
> small circle dimensions, etc., give different errors but none of these
> combinations seems to work.
> >
> > Also, in case the 2D mesh is correctly generated, the surface mesh
> quality is very bad in some points and the 3D mesh cannot be generated. I
> tried various options for the 2D and 3D mesh algorithms but none of them
> gives good results.
> >
> > What am I doing wrong?
> >
> The volume does not seem to be defined correctly. In all cases the surface
> mesh looks fine to me...
> Why don't you define all the curves as CAD entities?
> Christophe
> > I send you a minimal example of my geo script and the 1D mesh I use to
> define the inscribed circle.
> >
> > Thank you in advance,
> > bests,
> > Elisa
> >
> >
> >
> <circleLine2.mesh><testGmsh.geo><circleLine1.mesh>_______________________________________________
> > gmsh mailing list
> > gmsh at onelab.info
> > http://onelab.info/mailman/listinfo/gmsh
>> Prof. Christophe Geuzaine
> University of Liege, Electrical Engineering and Computer Science
> http://www.montefiore.ulg.ac.be/~geuzaine

Elisa Schenone, Ph. D.
Math Model Developer
mobile +39 3489213843
Moxoff SpA - Spinoff del Politecnico di Milano

<https://www.moxoff.com/>  <https://it.linkedin.com/company/moxoff-srl>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://onelab.info/pipermail/gmsh/attachments/20190920/74eea8d9/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ScreenshotGmsh.png
Type: image/png
Size: 242984 bytes
Desc: not available
URL: <http://onelab.info/pipermail/gmsh/attachments/20190920/74eea8d9/attachment-0002.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ScreenshotGmsh2.png
Type: image/png
Size: 247467 bytes
Desc: not available
URL: <http://onelab.info/pipermail/gmsh/attachments/20190920/74eea8d9/attachment-0003.png>

More information about the gmsh mailing list