[Gmsh] gmsh failes to construct 3D mesh from initial 2D surface mesh

Alexey Vasyukov vasyukov at gmail.com
Thu Aug 5 22:55:21 CEST 2010

2010/8/3 Christophe Geuzaine <cgeuzaine at ulg.ac.be>

> On 31/07/10 20:31, Alexey Vasyukov wrote:
>> Hi all.
>> I'm trying to use gmsh to construct 3D mesh from initial 2D surface
>> mesh. With some initial surface meshes it works and with others gmsh
>> crashes or hangs. You can find example meshes and steps to reproduce
>> problems in Trac - https://geuz.org/trac/gmsh/ticket/88
>> Could anybody point me in right direction how to fix it?
> I've looked at your files a bit more closely. They all work OK with the
> Delaunay. They cannot work with the Frontal algorithm because the surface
> mesh should be oriented with outward pointing normals in that case. Gmsh
> tries to orient the mesh correctly, but it does so "surface by surface". In
> your example the boundary of the volume is a single surface ("1") with
> non-coherent triangle orientations, so Gmsh cannot orient the triangles
> correctly.

I fixed normals orientation in input mesh and tried version 2.4.2 (binary,
Linux) and nightly builds of 2.5.0. I got strange result. If I launch GUI
and start 3D meshing from GUI - everything works fine. But if I launch it
from console (gmsh tetr-element-5.geo -3) - it fails with the same error as
I reported to Track.

Could you please point me what I am doing wrong? How can I make console mode
produce the same result that GUI mode produces?

Thanks in advance for your time and help.

Best regards,
Alexey Vasyukov
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.geuz.org/pipermail/gmsh/attachments/20100806/66075025/attachment.html>