[Gmsh] Gmsh/FiPy

Valentina soccorsov at gmail.com
Thu Jun 25 11:29:38 CEST 2015


Hi,

I’d like use Gmsh with FiPy. I installed FiPy and Gmsh and  they seem run well separatly.

I try to use Gmsh2D in FiPy and I received the following error message:


Traceback (most recent call last):
  File "explicit.py", line 7, in <module>
    mesh = Gmsh2D(os.path.splitext(__file__)[0] +'.msh')#, communicator=serialComm)
  File "/Library/Python/2.7/site-packages/FiPy-3.1-py2.7.egg/fipy/meshes/gmshMesh.py", line 1578, in __init__
    background=background)
  File "/Library/Python/2.7/site-packages/FiPy-3.1-py2.7.egg/fipy/meshes/gmshMesh.py", line 151, in openMSHFile
    raise EnvironmentError("Gmsh version must be >= 2.0.")
EnvironmentError: Gmsh version must be >= 2.0.

 I have also add to my .profile file the following text:

PATH="/Applications/Gmsh.app/Contents/MacOS:${PATH}
export PATH

but I didn’t have differences and if I write “gmsh –version” I receive: 

-bash: gmsh: command not found

Can you help me?

Thanks!

Valentina

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.geuz.org/pipermail/gmsh/attachments/20150625/a50879d1/attachment.html>


More information about the gmsh mailing list