[Gmsh] BUG (??) in version 4.5.6

Christophe Geuzaine cgeuzaine at uliege.be
Tue May 5 14:03:07 CEST 2020

> On 5 May 2020, at 12:34, miguel.ariza at artorg.unibe.ch wrote:
> Dear all,
> I was using a code I developed in version 4.4 for meshing spheres with tetrahedron. I could modify the characteristic length (max. and min.) and it worked perfectly.
> Moreover, I’ve been using this code in different incremental updates and it worked perfectly until version 4.5.3. Yesterday, I updated to version 4.5.6 and the code continues working but with a strange behavior.
> Let’s say that I was using a characteristic length of 0.2 for meshing a sphere, in version 4.5.3 this resulted in  ~70k elements. Now, with the same characteristics, this results in 1.000.000 elements!
> No matter what I tried, it seems that GMSH’s response was invariant:
> 	• Activate/deactivate the optimization of the mesh (it did not change anything)
> 	• Modify the characteristic length up to 2 or 4 (it did not change anything). Also, I debugged to be sure that these were the actual values that GMSH received
> 	• Try to use a bias in the mesh. Nothing
> Perhaps, I missed a major modification in the code from 4.5.3 to 4.5.6 and I need to re-code my libraries… but… Could it be a bug in the code? If so, where? In the meantime, I downgraded to version 4.5.3.

Could you send a simple example so that we can test?


> Tested in:
> 	• W10
> 	• Ubuntu 18.04 in WSL (W10)
> 	• Ubuntu 18.04
> Best,
> MA
> _______________________________________________
> gmsh mailing list
> gmsh at onelab.info
> http://onelab.info/mailman/listinfo/gmsh

Prof. Christophe Geuzaine
University of Liege, Electrical Engineering and Computer Science 

More information about the gmsh mailing list