[Gmsh] Problem with 2D meshes

Christophe Geuzaine cgeuzaine at ulg.ac.be
Mon Feb 12 17:46:58 CET 2007

Min Yan wrote:
> Dear list,
> I have some problem with *2D SECOND-ORDER* meshes generated by Gmsh 
> v2.0. My stand-alone code was doing fine with both msh1.0 and msh2.0 
> files saved by Gmsh v1.65, but fails for those saved by v2.0. I tried to 
> open and re-save the 'problematic' meshes in Gmsh v1.65 (open and 
> display fine) and that did not help a bit.
> I'm not completely sure (over 50% in confidence however) the fault is at 
> Gmsh 2.0. However if anybody have solved the same problem without any 
> crash when migrating from Gmsh 1.65 to v2.0, do let me know.

The default behavior in Gmsh 2.0 is to use "incomplete" second order 
elements (8-node quads, 20-node hexas, etc.). Maybe that's causing some 
trouble in your code?

You can revert to using "complete" second order elements by unselecting 
"Use imcomplete second order elements" in Options->Mesh->General.

> Regards,
> Min Yan
> ------------------------------------------------------------------------
> _______________________________________________
> gmsh mailing list
> gmsh at geuz.org
> http://www.geuz.org/mailman/listinfo/gmsh

Prof. Christophe Geuzaine
University of Liege, Electrical Engineering and Computer Science